Completed
Sovrn Platform Maintenance

Starts
February 15, 2022 at 10:02 PM
Status
Resolved after about 1 hour
Affects
Applications
meridian.sovrn.com
Applications
sovrn.com
Applications
platform.sovrn.com
Reporting
Ad Exchange Reporting
  • Completed
    February 15, 2022 at 10:49 PM

    Maintenance has completed successfully.

  • In progress
    February 15, 2022 at 10:02 PM

    We are currently undergoing planned maintenance at 3PM today. The Sovrn Platform will be unavailable during the maintenance period.