Resolved
New Logins to the Sovrn Platform are failing.

Started
July 05, 2022 at 4:52 PM
Status
Resolved after about 11 hours
Affected
Applications
meridian.sovrn.com
Applications
commerce.sovrn.com
Applications
platform.sovrn.com

Impact

Operational
  • Resolved
    July 06, 2022 at 3:30 AM

    The outage has been resolved with our third-party service. All features should be functioning again.

  • Monitoring
    July 05, 2022 at 8:33 PM

    We have implemented a fix to allow access into the Sovrn Platform. However, some newer features are still inaccessible until our third-party service has resolved their outage. The latest update from the third-party is that they have identified the problem and are currently in the process of resolving the issue. Some of their services are starting to become healthy again, but some portions of their service are still impacted.

  • Identified
    July 05, 2022 at 4:52 PM

    We have identified a third-party service used by the Sovrn Platform is currently experiencing a major outage, which is causing logins to the Sovrn Platform to fail. We will update as soon as we know more from the third-party service.