Sovrn - Management Actions Temporarily Unavailable – Incident details
Report an issue
Get updates
Email
Slack
Microsoft Teams
Google Chat
Webhook
RSS
Atom
API
Report an issue
Get updates
Dark mode
All systems operational
Management Actions Temporarily Unavailable
Resolved
Major outage
Started 9 days ago
Lasted 1 day
Updates
Resolved
March 13, 2026 at 8:08 PM
Resolved
March 13, 2026 at 8:08 PM
This incident has been resolved.
Identified
March 12, 2026 at 6:00 PM
Identified
March 12, 2026 at 6:00 PM
Some Sovrn users may currently be unable to create or modify Ad tags, Properties, or Ad quality blocks. Our team is actively working on a fix. We’ll provide an update as soon as the issue is resolved.