Sovrn.co Link Activation

Resolved
Operational
Started over 1 year ago Lasted about 4 hours

Affected

Products
Commerce
Updates
  • Resolved
    Resolved

    This issue is now resolved. All sovrn.co links created during this time should now be functioning.

  • Investigating
    Investigating

    We are currently investigating an issue that may delay the activation of newly created sovrn.co links. We are working to resolve this as soon as possible. We appreciate your patience and will post updates on our status page.