Sovrn.co Links may not be directed to their destination

Resolved
Operational
Started about 1 year ago Lasted about 1 hour

Affected

Products
Commerce
Updates
  • Resolved
    Resolved

    This incident has been resolved.

  • Investigating
    Investigating

    We are currently investigating an issue causing sovrn.co shortened links to redirect to a 500.